I suggest you ...

Improve performance

Tried circuibee in both Firefox 5.0 and Chrome 14 on Ubuntu 11.04.
Performance is terrible. In Chrome, panning the circuit doesn't properly erase the last frame, resulting in muck. Very slow on FF5.0

2 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    John Hughes shared this idea  ·   ·  Admin →

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Tom Boyd commented  · 

        15 Nov 2011: With Firefox 8.0, an old XP machine and a poor internet connection I was getting excellent results from a random sampling of the "public" circuits at the CircuitBee website.

      • AdminBen (Founder, CircuitBee) commented  · 

        Hi John,

        You're the second person with an issue in Chrome 14, but that is a development build of Chrome so issues are to be expected, especially since changes to hardware accelerated Canvas are still being made. We are having trouble reproducing these issues at the moment using the latest Chrome Canary install, which specific version are you using?

        FireFox 5 has Hardware Acceleration turned on by default, some people are seeing that this actually decreases performance. You can disable it in the about:config page. Filter: /gfx|layers/. That might improve matters for you, though in our testing Chrome has always performed better than FireFox.

        We are however going to be looking to improve the performance, and there are some optimisations that we have not yet implemented, so you can expect performance to get better in the weeks/months ahead.

      Feedback and Knowledge Base